Coder Social home page Coder Social logo

tokyonight.nix's Introduction

tokyonight.nix

A Nix Flake providing a home-manager module to apply the popular tokyonight colorscheme to your favorite apps.

Contributions Welcome!

If you don't see an app supported, please feel free to add it via a PR!

Usage

Consume the flake however you normally would in your Nix setup, then you can do:

{
  imports = [ tokyonight.homeManagerModules.default ];
  # or night, moon, or day
  tokyonight.style = "storm";
  # enable globally for all supported programs
  tokyonight.enable = true;
  # or, enable individual programs;
  # note that this is not needed if `tokyonight.enable = true;` is set
  programs = {
    git.delta.tokyonight.enable = true;
    bat.tokyonight.enable = true;
    fish.tokyonight.enable = true;
    fzf.tokyonight.enable = true;
    rofi.tokyonight.enable = true;
  };
  # you can also customize style on a per-program basis
  programs.fzf.tokyonight.style = "day";
}

The list of supported modules can be found in ./modules/home-manager.

Special Cases

Wezterm

Wezterm has the theme built-in, and doesn't have a good way for this flake to set it up for you, since it's mostly configured through the extraConfig field with Lua, so you will need to just put the following in your Lua config:

-- If using `local config = wezterm.config_builder()`
config.color_scheme = 'tokyonight_night' -- or tokyonight_day, or whatever style

-- otherwise
return {
  color_scheme = 'tokyonight_night', -- or tokyonight_day, or whatever style
  -- rest of your config here
}
btop

btop has tokyo-night and tokyo-storm built-in. If you're using one of those, you can set the following in your Nix config.

programs.btop.settings.color_theme = "tokyo-night" # or tokyo-storm

If you are using one of the other variants of Tokyonight, you can get a pretty good approximation for btop by using tokyo-night with a transparent background:

programs.btop.settings = {
  color_theme = "tokyo-night" # or tokyo-storm
  theme_background = false;
};

Acknowledgements

Inspired by all the hard work on the Catppuccin Nix Flake!

tokyonight.nix's People

Contributors

mrjones2014 avatar

Stargazers

 avatar

Watchers

 avatar

tokyonight.nix's Issues

Recommend Projects

  • React photo React

    A declarative, efficient, and flexible JavaScript library for building user interfaces.

  • Vue.js photo Vue.js

    🖖 Vue.js is a progressive, incrementally-adoptable JavaScript framework for building UI on the web.

  • Typescript photo Typescript

    TypeScript is a superset of JavaScript that compiles to clean JavaScript output.

  • TensorFlow photo TensorFlow

    An Open Source Machine Learning Framework for Everyone

  • Django photo Django

    The Web framework for perfectionists with deadlines.

  • D3 photo D3

    Bring data to life with SVG, Canvas and HTML. 📊📈🎉

Recommend Topics

  • javascript

    JavaScript (JS) is a lightweight interpreted programming language with first-class functions.

  • web

    Some thing interesting about web. New door for the world.

  • server

    A server is a program made to process requests and deliver data to clients.

  • Machine learning

    Machine learning is a way of modeling and interpreting data that allows a piece of software to respond intelligently.

  • Game

    Some thing interesting about game, make everyone happy.

Recommend Org

  • Facebook photo Facebook

    We are working to build community through open source technology. NB: members must have two-factor auth.

  • Microsoft photo Microsoft

    Open source projects and samples from Microsoft.

  • Google photo Google

    Google ❤️ Open Source for everyone.

  • D3 photo D3

    Data-Driven Documents codes.