Coder Social home page Coder Social logo

angular-language-server.nix's Introduction

language-servers.nix

(mostly just a fork of language-servers.nix with the other language servers removed, since they're mostly available through nixpkgs, and angular-language-server set as the default package)

Angular Language Server

It provides bin/ngserver from vscode-ng-language-service with the wrapped command line arguments --add-flags --ngProbeLocations $out/node_modules --tsProbeLocations ${pkgs.typescript}/node-modules. A typical usage of this server is to provide just the --stdio flag.

Besides the wrapped version it includes bin/angular-language-server-unwrapped and this one does not set any command line arguments by default. This requires to provide the --ngProbeLocations and the --ngProbeLocations arguments to the script.

The currently used packages are visible through angular-language-server/package.json.

How to use this?

Include the flake into your flake which defines the dev shell, e.g.:

{
  inputs = {
    nixpkgs.url = "github:nixos/nixpkgs";
    angular-language-server.url = "github:junglerobba/angular-language-server.nix";
    angular-language-server.inputs.nixpkgs.follows = "nixpkgs";
    flake-utils.url = "github:numtide/flake-utils";
  };

  outputs = { self, nixpkgs, angular-language-server, flake-utils }:
    flake-utils.lib.eachDefaultSystem (system:
      let
        pkgs = nixpkgs.legacyPackages.${system};
        pkgs = import nixpkgs {
          inherit system;
          # provides an overlay and a default package
          overlays = [ angular-language-server.overlays.default ];
        };
        nodejs = pkgs.nodejs_22;
      in {
        devShell = pkgs.mkShell {
          packages = with pkgs; [
            nodejs
            # can also override node version used
            (angular-language-server.override {
              inherit nodejs;
            })
          ];
        };
      });
}

License

ISC

angular-language-server.nix's People

Contributors

bwolf avatar junglerobba avatar

Watchers

 avatar

Recommend Projects

  • React photo React

    A declarative, efficient, and flexible JavaScript library for building user interfaces.

  • Vue.js photo Vue.js

    ๐Ÿ–– Vue.js is a progressive, incrementally-adoptable JavaScript framework for building UI on the web.

  • Typescript photo Typescript

    TypeScript is a superset of JavaScript that compiles to clean JavaScript output.

  • TensorFlow photo TensorFlow

    An Open Source Machine Learning Framework for Everyone

  • Django photo Django

    The Web framework for perfectionists with deadlines.

  • D3 photo D3

    Bring data to life with SVG, Canvas and HTML. ๐Ÿ“Š๐Ÿ“ˆ๐ŸŽ‰

Recommend Topics

  • javascript

    JavaScript (JS) is a lightweight interpreted programming language with first-class functions.

  • web

    Some thing interesting about web. New door for the world.

  • server

    A server is a program made to process requests and deliver data to clients.

  • Machine learning

    Machine learning is a way of modeling and interpreting data that allows a piece of software to respond intelligently.

  • Game

    Some thing interesting about game, make everyone happy.

Recommend Org

  • Facebook photo Facebook

    We are working to build community through open source technology. NB: members must have two-factor auth.

  • Microsoft photo Microsoft

    Open source projects and samples from Microsoft.

  • Google photo Google

    Google โค๏ธ Open Source for everyone.

  • D3 photo D3

    Data-Driven Documents codes.