Coder Social home page Coder Social logo

datadog.nix's Introduction

Work In Progress

This is a work-in-progress and might not even be functional at the moment. Once we have deployed this into production, we will remove this notice.

nix-datadog

This flake is a fork and rewrite of the official nixpkgs datadog-agent package and its associated NixOS module.

The goal of this fork is to test a new package/module interface before proposing its merge upstream into nixpkgs.

We are using this flake internally at Quartzy, where we use Nix to manage our entire infrastructure from development to production. If you'd like to help advance scientific research while getting to work with Nix, we are hiring.

Install

This is a standard Nix flake with flake-compat. If you want to use the flakes, add this repo as you would any other flake. This flake has three outputs:

  • packages.<system>.default: the Datadog environment, described in more detail below.
  • overlays.default: an overlay making the above package available under the top level key pkgs.datadog.
  • nixosModules.default: a NixOS module to manage the Datadog Agent(s) and configs on a NixOS machine.

If you are not using flakes, compatibility is provided via flake-compat. Use niv or a URL fetcher to get the source of this repository, then just import default.nix, module.nix or overlay.nix and use as you would any other package, overlay, or NixOS module.

Usage

If all you want to do is setup Datadog on your server:

{
  services.datadog.enable = true;
}

The NixOS module will try to detect which services you have enabled, and enable their associated integrations automatically. You can override this behavior by passing in your own Datadog environment using the package helper functions:

{ pkgs, ... }:

{
  services.datadog = {
    enable = true;
    package = pkgs.datadog.withIntegrations ({ all, enabled, ... }: with all; enabled ++ [
      nginx
      php-fpm
      postgres
      redisdb
    ]);
  };
}

You can see the full list of integrations in ./integrations.nix.

datadog.nix's People

Contributors

tristanpemble avatar jakelogemann avatar

Watchers

 avatar

Recommend Projects

  • React photo React

    A declarative, efficient, and flexible JavaScript library for building user interfaces.

  • Vue.js photo Vue.js

    ๐Ÿ–– Vue.js is a progressive, incrementally-adoptable JavaScript framework for building UI on the web.

  • Typescript photo Typescript

    TypeScript is a superset of JavaScript that compiles to clean JavaScript output.

  • TensorFlow photo TensorFlow

    An Open Source Machine Learning Framework for Everyone

  • Django photo Django

    The Web framework for perfectionists with deadlines.

  • D3 photo D3

    Bring data to life with SVG, Canvas and HTML. ๐Ÿ“Š๐Ÿ“ˆ๐ŸŽ‰

Recommend Topics

  • javascript

    JavaScript (JS) is a lightweight interpreted programming language with first-class functions.

  • web

    Some thing interesting about web. New door for the world.

  • server

    A server is a program made to process requests and deliver data to clients.

  • Machine learning

    Machine learning is a way of modeling and interpreting data that allows a piece of software to respond intelligently.

  • Game

    Some thing interesting about game, make everyone happy.

Recommend Org

  • Facebook photo Facebook

    We are working to build community through open source technology. NB: members must have two-factor auth.

  • Microsoft photo Microsoft

    Open source projects and samples from Microsoft.

  • Google photo Google

    Google โค๏ธ Open Source for everyone.

  • D3 photo D3

    Data-Driven Documents codes.