Coder Social home page Coder Social logo

pigpio-vast's People

Stargazers

 avatar

Watchers

 avatar  avatar  avatar  avatar

Forkers

emaringolo

pigpio-vast's Issues

Rename all Gpio to Pigpio

In many places of the RaspberryHardware core refers to the word GPIO instead of Pigpiod. Examples is the classes RaspberryGpioDaemonInterface and RaspberryGpioInterface. In that case the "Gpio" is not really GPIO as the phisical pin (hardware) but the LIBRARY. Therefore, that must be Pigpio.

There are probably other places than these 2 class names where it calls "Gpio" instead of "Pigpiod". We should try to rename as much as we can see.

Make GPIOPortMCP23017 more general and support native GPIOs

Right now, GPIOPortMCP23017 works with a device. The API of that device is basically a subset of I2CDeviceGPIOMCP23017. I believe that subset of functionality / API should eventually be moved up in the hierarchy (to I2cDevice or GpioBusDevice). That way, GPIOPortMCP23017 could be renamed to GPIOPort and depending on which device you pass, it would use either the GPIOs of MCP23017 or the native ones.

At this point, it would also be interesting to think if those GpioBusDevice and similar GPIO* classes should be renamed to Pigpio*.

Better document that we cannot use RaspberryGpioInterface but RaspberryGpioDaemonInterface

We should explain better that in VAST, we can only use RaspberryGpioDaemonInterface so far and that RaspberryGpioInterface crashes the VM. We should put that as class comments or even rename RaspberryGpioInterface to RaspberryGpioInterfaceBROKEN or move it to a separate subclass or something. In addition, we can implement RaspberryGpioInterface class >> raspberryGpioStart doing a self error: 'not supported... use daemon instead....

OneWireDS18B20ThermometerDevice>temperature problem

OneWireDS18B20ThermometerDevice>temperature fails to close the file after reading it. See new code below.

temperature
"Answer the current temperature value of this device. It is possible the device may not have reported a correct list
of data, so return 999 as a placeholder"
| file data pos tStr |

file := CfsReadFileStream open: devFilePath.
file isCfsError ifFalse: [
	data := file contents.
            file close.                                    "This is the new line."
	((data indexOfSubCollection: 'YES') > 0) ifTrue: [
		pos := data indexOfSubCollection: 't='.
		(pos > 0) ifTrue: [
			tStr := data copyFrom: pos + 2 to: data size.
			^tStr asNumber / 1000.0.
		].
	].
].
^999.

Recommend Projects

  • React photo React

    A declarative, efficient, and flexible JavaScript library for building user interfaces.

  • Vue.js photo Vue.js

    ๐Ÿ–– Vue.js is a progressive, incrementally-adoptable JavaScript framework for building UI on the web.

  • Typescript photo Typescript

    TypeScript is a superset of JavaScript that compiles to clean JavaScript output.

  • TensorFlow photo TensorFlow

    An Open Source Machine Learning Framework for Everyone

  • Django photo Django

    The Web framework for perfectionists with deadlines.

  • D3 photo D3

    Bring data to life with SVG, Canvas and HTML. ๐Ÿ“Š๐Ÿ“ˆ๐ŸŽ‰

Recommend Topics

  • javascript

    JavaScript (JS) is a lightweight interpreted programming language with first-class functions.

  • web

    Some thing interesting about web. New door for the world.

  • server

    A server is a program made to process requests and deliver data to clients.

  • Machine learning

    Machine learning is a way of modeling and interpreting data that allows a piece of software to respond intelligently.

  • Game

    Some thing interesting about game, make everyone happy.

Recommend Org

  • Facebook photo Facebook

    We are working to build community through open source technology. NB: members must have two-factor auth.

  • Microsoft photo Microsoft

    Open source projects and samples from Microsoft.

  • Google photo Google

    Google โค๏ธ Open Source for everyone.

  • D3 photo D3

    Data-Driven Documents codes.