Coder Social home page Coder Social logo

pv-terms's People

Contributors

cwhanse avatar kandersolar avatar mdeceglie avatar toddkarin avatar

Stargazers

 avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar

Watchers

 avatar  avatar  avatar  avatar  avatar  avatar

pv-terms's Issues

Temperature units for Celsius

The temperature units are currently expressed as C, which is technically the SI symbol for coulomb. For parameters like temperature_cell Celsius is natural, so I suggest using °C. For units where temperature appears in the denominator, kelvin may be more appropriate. For example, in Table 4 on this NIST site derived units use kelvin.

bifacial pv terms

Hello,

Just learned of this effort and it makes me so happy it's happening! 👯

Can we add a list of bifacial terms to this? That would also mean adding clarification to terms like
poa, from:

poa_direct [W/m^2]: Direct/beam irradiation in plane.

to

poa_direct [W/m^2]: Direct/beam irradiation in plane. In case of bifacial systems, poa considers front and back irradiances.

We are in the middle of a IEA report on bifacial, and it has helped come up with the terms and synonyms as well as nuanced differences for many of these. I can gather them in the next weeks and do a PR if we want to add that section.

p_mp vs. pmp

I was working on some modeling with pvlib, and it uses a relatively consistent naming scheme of the form p_mp, v_oc throughout. For pvterms, we decided not to use one-letter abbreviations from @bmeyers suggestion. Instead we use variables like pmp, and pmp_ref.

I just want to double-confirm this important decision, since it seems like our new scheme is somewhat better, but will make integration with pvlib much more difficult. @cwhanse , @mdeceglie , @kanderso-nrel what do you think?

voc, beta_voc vs. voltage_oc, beta_oc

Should we define abbreviations voc, vmp, beta_voc or use voltage_oc, voltage_mp, beta_oc? Similar question for related params and temperature coefficients.

Better organize PV System and PV Power Plant categories

Proposal:

  • put inverter parameters in a new section
  • PV System, containing variables related to current, voltage and power, could be "DC output" or "DC Power". transposition_factor doesn't belong here. "spectral_mismatch" belongs with "effective_irradiance" perhaps.
  • PV System should contain variables related to the physical PV system, including many quantities (modules_per_string, module_temperature) in PV Power Plant.
  • I'm -1 (x 3) on the "_XX" pattern. If the intent is to "demonstrate a naming scheme", OK, but let's keep the base names "voltage_dc" etc. in the glossary, and demonstrate a naming scheme using these base variables in an Examples section.

Terms in incorrect sections

I suggest that the sections for several terms should be shuffled a bit.

The following terms should be moved to the "Inverter" section:

  • efficiency_inverter
  • efficiency_inverter_eu
  • efficiency_inverter_cec

spectral_mismatch should be moved to the "Module Parameters" section

Term for direct/beam horizontal irradiance

It would be beneficial to also include a term for direct/beam horizontal irradiance as this is also frequently used. E.g., reanalysis data often only include direct/beam horizontal irradiance and not the normal component.

The solar resource community has not decided on a standard abbreviation, as the most straightforward naming, "Direct Horizontal Irradiance", would clash with the already existing term Diffuse Horizontal Irradiance (DHI). For this reason, some use the term Beam Normal Irradiance (BNI) instead of DNI and then Beam Horizontal Irradiance (BHI).

pv-terms could consider adopting the BHI acronym or perhaps an even better alternative?

Additional variable names request

I'm trying to get my code for the Loss Factors and Mechanistic Performance Models working using this naming convention before the workshop on 5th Aug https://pvpmc.sandia.gov/7865-2/

There are a few parameters I found missing that may be useful to all and there will be a few that are maybe MLFM specific.
I've made a list with suggested variable names, maybe they can be added, or let me know whether they already exist, or if they should just be calculations in my code..

Useful for all

_norm (suffix for normalised measurements)
	
date_time	(suggest format YYYY-MM-DDTHH:MM:SS) or maybe pandas datetime?
wind_speed	(ms^-1)
wind_direction	(degrees)
poa_global_cSi	(unfiltered ref cell)
poa_global_cSi_kg3	(filtered reference cell)
gni	(global normal irradiance) (kW/m2)
relative_humidity	(%)
air_mass	(number)
xbi	(extraterrestrial beam irradiance) or xni?? (kW/m2)
xhi	(extraterrestrial horizontal  irradiance) (kW/m2)
kTh	(clearness index horizontal = ghi/xhi) (%)
kTn	(clearness index normal gni/xbi) (%)

beam_fraction	= (1- dhi/ghi) (%)
direct_fraction	= (dhi/ghi) (%)

Used by MLFM
rsc = -1/(dV/dI)|V=0 (Ohms)
roc = -1/(dV/dI)|V=Voc (Ohms)
i_half_vmp = current at Vmp/2 (A)
v_half_imp =voltage at Imp/2 (V)

Any help welcome!

Irradiance data abbreviations

A few comments

  1. you use lowercase, often abrevations of dni, ghi etc... are upper case

  2. DHI sometimes stands for diffuse horizontal irradiance. Maybe you could add DIF (or dif) then in the list to cover both direct and diffuse?

  3. In addition to poa, I'd suggest to add gti: global tilted irradiance. This is more frequently used in Europe than poa.

Temperature coefficient labels

It is a little strange to use beta_voc_ref for the temperature coefficient. Most people would prefer to use beta_voc to mean the temperature coefficient of Voc near reference conditions. Shall we remove the _ref suffix for these variables that are generally understood to be at reference conditions?

@cwhanse, @mdeceglie let me know what you think.

README

Should the README be "Standard variable names for PV modeling?" "Nomenclature for PV systems" is too broad.

Set of labels for different technologies

We should also standardize the labeling for different technologies, for example, pvlib.ivtools.fit_sdm_cec_sam uses the list:

  • 'monoSi', 'multiSi', 'polySi', 'cis', 'cigs', 'cdte', 'amorphous'

while the cec database pvlib.pvsystem.retrieve_sam uses:

  • 'Thin Film', 'Multi-c-Si', 'CIGS', 'Mono-c-Si', 'CdTe'

PVsyst on the other hand uses:

  • Si-poly, Si-mono, and others.

Without giving this too much thought, I would probably pick the first option and add this to pvterms. @cwhanse what do you think?

Gantner/SRCL feedback on naming convention

SRCL_GI_PVPMC_naming_200430t093.pdf

Steve Ransome (SRCL) and Juergen Sutterlueti (Gantner Instruments) have been working with Gantner instruments for many years to help them develop a naming convention which they've been using, here are some constructive comments including problems we'd seen and had to overcome.

We look forward to contributing and answering any comments.

Allow prefix construction

In some cases the suffix construction required by pv-terms reduces code readability. Example

In this case meas_global_poa is more readable than poa_global_meas.

Allowing for prefix or suffix construction will allow projects seeking to use pv-terms more flexibility to meet their respective needs.

alpha_isc

@cwhanse Technically, alpha_isc depends on temperature. Should we use alpha_isc_ref for alpha_isc at reference conditions and alpha_isc at any temperature?

Insolation terms

The list doesn't include terms for insolation (integrated irradiance, Wh/m^2). Seems like most or all of the terms in the "Irradiance" category could have insolation equivalents.

Recommend Projects

  • React photo React

    A declarative, efficient, and flexible JavaScript library for building user interfaces.

  • Vue.js photo Vue.js

    🖖 Vue.js is a progressive, incrementally-adoptable JavaScript framework for building UI on the web.

  • Typescript photo Typescript

    TypeScript is a superset of JavaScript that compiles to clean JavaScript output.

  • TensorFlow photo TensorFlow

    An Open Source Machine Learning Framework for Everyone

  • Django photo Django

    The Web framework for perfectionists with deadlines.

  • D3 photo D3

    Bring data to life with SVG, Canvas and HTML. 📊📈🎉

Recommend Topics

  • javascript

    JavaScript (JS) is a lightweight interpreted programming language with first-class functions.

  • web

    Some thing interesting about web. New door for the world.

  • server

    A server is a program made to process requests and deliver data to clients.

  • Machine learning

    Machine learning is a way of modeling and interpreting data that allows a piece of software to respond intelligently.

  • Game

    Some thing interesting about game, make everyone happy.

Recommend Org

  • Facebook photo Facebook

    We are working to build community through open source technology. NB: members must have two-factor auth.

  • Microsoft photo Microsoft

    Open source projects and samples from Microsoft.

  • Google photo Google

    Google ❤️ Open Source for everyone.

  • D3 photo D3

    Data-Driven Documents codes.