Coder Social home page Coder Social logo

flake.nix's People

Contributors

luochen1990 avatar oluceps avatar piyoki avatar ryan4yin avatar sumire88 avatar

Stargazers

 avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar

Watchers

 avatar  avatar

flake.nix's Issues

daed is unusable

I tried to setup using config in readme.

services.daed = {
      enable = true;

      openFirewall = {
        enable = true;
        port = 12345;
      };

      /* default options

      package = inputs.daeuniverse.packages.x86_64-linux.daed;
      configDir = "/etc/daed";
      listen = "127.0.0.1:2023";

      */
  };

But the log shows that:

08:00" level=warning msg="dangerous converting: may exceeds graphQL int32 range" name=SoMarkFromDae type=uint32
08:00" level=warning msg="dangerous converting: may exceeds graphQL int32 range" name=SoMarkFromDae type=uint32
08:00" level=info msg="Loading eBPF programs and maps into the kernel..."
08:00" level=info msg="The loading process takes about 120MB free memory, which will be released after loading. Insu>
08:00" level=info msg="Listen on 127.0.0.1:2023"
08:00" level=fatal msg="dae.Run: load eBPF objects: field TproxyLanIngress: program tproxy_lan_ingress: load program>
 exited, code=exited, status=1/FAILURE

dae works fine for me BTW.

vendorHash mismatch error on build

[nix-shell:~/nixos-config]$ sudo nixos-rebuild switch
warning: updating lock file '/home/meowking/nixos-config/flake.lock':
• Updated input 'daeuniverse':
    'github:daeuniverse/flake.nix/58124931de72166dda3567b5a53fcc615763f3d7' (2024-04-02)
  → 'github:daeuniverse/flake.nix/ed270befb65251a6d6ad88403980a5186813464f' (2024-04-03)
building the system configuration...
error: hash mismatch in fixed-output derivation '/nix/store/7dv8qg29bqa0829gmz8q3al16j9vnnkd-dae-v0.6.0rc1-go-modules.drv':
         specified: sha256-NzPPf/KwuRCMmOGwk9k3ndYojDF9B/hXBPQ8ySan3t8=
            got:    sha256-GT8XD+9YVKXyUfBiN8+Vry3CyWXd+2zyYNb3/TRloLo=
error: 1 dependencies of derivation '/nix/store/hkr0hjxj3r4r30ygnds9vp857q7rfpam-dae-v0.6.0rc1.drv' failed to build
error: 1 dependencies of derivation '/nix/store/jdfv8vgs7404qd9dry0s8xz4xy6biigw-system-generators.drv' failed to build
error: 1 dependencies of derivation '/nix/store/3i8p07lin55q9gkx2mbrx7v2n2jbc1rd-system-path.drv' failed to build
error: 1 dependencies of derivation '/nix/store/70an5bqpgs691d9pl791chaih5bsi9gf-nixos-system-meowos-24.05.20240329.d8fe5e6.drv' failed to build

This is my flake.nix:

{
  description = "MeowKing's NixOS Flake Configuration";

  inputs = {
    nixpkgs.url = "github:nixos/nixpkgs?ref=nixos-unstable";
    daeuniverse.url = "github:daeuniverse/flake.nix";
  };

  outputs = { self, nixpkgs, ... }@inputs : {
    nixosConfigurations.meowos = nixpkgs.lib.nixosSystem {
      system = "x86_64-linux";
      specialArgs = { inherit inputs; };
      modules = [
        ./configuration.nix
	inputs.daeuniverse.nixosModules.dae
      ];
    };
  };
}

And this is the relevant parts of my configuration.nix file:

  environment = {
    sessionVariables = {
      GO111MODULE = "on";
      GOPROXY = "https://goproxy.io,direct";
    };
  };
  services = {
    dae = {
      enable = true;
      openFirewall = {
        enable = true;
        port = 12345;
      };
      configFile = "/etc/dae/config.dae";
    };
  };

I put GOPROXY into sessionVariables since I cannot directly download go packages.(IDW whether it is the source of this issue)
I've tried to build dae with and without binary cache. However, both failed.

Actually perform automated update

Hi! Currently there seems to be an automated update workflow via nix-update, but that workflow requires manual dispatch and last run is 4mo ago; The flake is currently tacking an August version. See:

version = "unstable-2023-08-22";

Maybe a webhook or a step in dae&daed's CI could be added to update this flake when a new version is published?

failed to load new config

Hello,I just installed daed using nixosmodules while I can't get it work.
I'm using:

  services.daed = {
    enable = true;
    package = daeuniverse.packages.x86_64-linux.daed; # default
    configDir = "/etc/daed";
    listen = "0.0.0.0:2023";
    openFirewall = {
      enable = true;
      port = 12345;
    };
  };

when I click proxy switch,I get this:

failed to load new config: ApplyRulesOptimizers error: geoip.dat: file does not exist in [/etc/daed, /root/.local/share/daed, /usr/local/share/daed, /usr/share/daed]; see more in log

Recommend Projects

  • React photo React

    A declarative, efficient, and flexible JavaScript library for building user interfaces.

  • Vue.js photo Vue.js

    🖖 Vue.js is a progressive, incrementally-adoptable JavaScript framework for building UI on the web.

  • Typescript photo Typescript

    TypeScript is a superset of JavaScript that compiles to clean JavaScript output.

  • TensorFlow photo TensorFlow

    An Open Source Machine Learning Framework for Everyone

  • Django photo Django

    The Web framework for perfectionists with deadlines.

  • D3 photo D3

    Bring data to life with SVG, Canvas and HTML. 📊📈🎉

Recommend Topics

  • javascript

    JavaScript (JS) is a lightweight interpreted programming language with first-class functions.

  • web

    Some thing interesting about web. New door for the world.

  • server

    A server is a program made to process requests and deliver data to clients.

  • Machine learning

    Machine learning is a way of modeling and interpreting data that allows a piece of software to respond intelligently.

  • Game

    Some thing interesting about game, make everyone happy.

Recommend Org

  • Facebook photo Facebook

    We are working to build community through open source technology. NB: members must have two-factor auth.

  • Microsoft photo Microsoft

    Open source projects and samples from Microsoft.

  • Google photo Google

    Google ❤️ Open Source for everyone.

  • D3 photo D3

    Data-Driven Documents codes.